Print | Rate this content

Advisory: HP Smart Array Controllers - "Inconsistent Stripe" Event with RAID 1 or RAID 1+0 Logical Drives May Be Generated Under Normal Operating Conditions on Smart Array Controllers Running Certain Versions of Firmware

SUPPORT COMMUNICATION - CUSTOMER ADVISORY

Document ID: c01686968

Version: 1

Advisory: HP Smart Array Controllers - "Inconsistent Stripe" Event with RAID 1 or RAID 1+0 Logical Drives May Be Generated Under Normal Operating Conditions on Smart Array Controllers Running Certain Versions of Firmware
NOTICE: The information in this document, including products and software versions, is current as of the Release Date. This document is subject to change without notice.

Release Date: 2009-03-09

Last Updated: 2009-03-06


DESCRIPTION

On the following HP Smart Array controllers running certain firmware versions, an "Inconsistent Stripe" event may be generated for a RAID 1 or RAID 1+0 logical drive, even though the system is operating under normal conditions:

  • Smart Array P400, P800, or E500 Controllers running firmware versions 5.20 through 5.24
  • Smart Array P700m Controllers running firmware versions 5.60 through 6.28
  • Smart Array P212, P410, and P411 Controllers running firmware version 1.06

Beginning with the Smart Array controller firmware versions listed above and Array Diagnostic Utility (ADU) Version 8.00, a change was made that causes the system to misinterpret normal OS-related buffer content changes as "critical" in ADU. As a result of this issue,"inconsistent stripe" events are being observed in the operating system event log. The operation and functionality of the system, including data residing on the logical drive, is not affected by inconsistent stripe messages that result from normal OS-related buffer content changes.

Updated versions of Smart Array Controller firmware and an updated version of the ADU have been developed to correct this issue.

When this occurs on systems running Microsoft Windows, if the HP Smart Array SAS/SATA Event Notification Service is loaded, an event similar to the following may be found in the Windows System Event log:

System Event ID DateTime mm/dd/yyyy hh:mm
Type: Warning
Category: None
EventID: 24607
Source: Cissesrv
Computer: Computer-Name
User: N/A
Message: The event information received from array controller P400
located in server slot 9 was of an unknown or unrecognized class.
An excerpt of the controller message is as follows:
Inconsistent stripe, LDrv=0 LBA=x-y

When this occurs on systems running Linux with HP Insight Management Agents loaded, an event similar to the following may appear in the /var/log/messages file:

cmaeventd[4305]: Inconsistent stripe, LDrv=0 LBA=x-y

After receiving this event, if the HP Array Diagnostic Utility (ADU) Version 8.00 through 8.25 is run, the ADU Surface Analysis Status section will report that the consistency check has failed as follows:

For Windows, the HP Smart Array SAS/SATA event notification service must be running in order to receive the "inconsistent stripe" event. For Linux, the HP Insight Management Agents must be running to receive the "inconsistent stripe" event. If the service or agents are not running, the ADU report will still indicate that the consistency check failed, but the "inconsistent stripe" event will not be observed.

SCOPE

Any ProLiant server configured with one of the following Smart Array controllers, with RAID 1 or RAID 1+0 logical drives configured, and the event service or agent loaded:

  • Smart Array P400, P800, or E500 Controllers running firmware versions 5.20 through 5.24
  • Smart Array P700m Controllers running firmware versions 5.60 through 6.28
  • Smart Array P212, P410, and P411 Controllers running firmware version 1.06

The Event Log/Var log message is only displayed for the Smart Array controllers listed above in a RAID1/1+0 configuration. However, the "inconsistent stripe" status may also be observed when running Array Diagnostic Utility (ADU) versions between 8.00 and 8.25 when the server is configured with any Smart Array Controller in a RAID 1/1+0 configuration.

Note: While this event has been observed in Microsoft Windows and Linux environments, it could occur in other operating systems.

RESOLUTION

To ensure that Smart Array P400, P800 or E500 controllers do not misinterpret normal OS-related buffer content changes as "critical," upgrade to firmware version 5.26, available as follows:

  1. Navigate to:

    http://www.hp.com/#Support

  2. Under Step 1, select "Download Software and Drivers."
  3. Under Step 2, type in the name of the Smart Array Controller; for example, "Smart Array P400" and click the "Go" button.
  4. When the product page appears, select the appropriate operating system.
  5. Click on the Firmware-Storage Controller category.
  6. Select the Online ROM Flash Component Version 5.26 and click "Download."

To ensure that Smart Array P212, P410, and P411 Controllers do not misinterpret normal OS-related buffer content changes as "critical," upgrade to firmware version 1.58, available as follows:

Windows: ftp://ftp.hp.com/pub/softlib2/software1/sc-windows-fw-array/p1095672758/v52119/

Linux: ftp://ftp.hp.com/pub/softlib2/software1/sc-linux-fw-array/p1997486963/v52180/

To ensure that Array Diagnostic Utility does not incorrectly report an "Inconsistency Check Failed" event as "Critical," upgrade to ADU Version 8.26:

  1. Navigate to:

    http://www.hp.com/#Support

  2. Under Step 1, select "Download Software and Drivers."
  3. Under Step 2, type in the name of the Smart Array Controller; for example, "Smart Array P400" and click the "Go" button.
  4. When the product page appears, select the appropriate operating system.
  5. Click on the Software-System Management category.
  6. Select the Array Diagnostics Utility Version 8.26 and click "Download."

This advisory will be revised when the updated version of firmware for the Smart Array P700m Controller becomes available.

RECEIVE PROACTIVE UPDATES : Receive support alerts (such as Customer Advisories), as well as updates on drivers, software, firmware, and customer replaceable components, proactively via e-mail through HP Subscriber's Choice. Sign up for Subscriber's Choice at the following URL:


NAVIGATION TIP : For hints on navigating HP.com to locate the latest drivers, patches, and other support software downloads for ProLiant servers and Options, refer to the Navigation Tips document .
SEARCH TIP : For hints on locating similar documents on HP.com, refer to the Search Tips document .

Hardware Platforms Affected: HP Smart Array E500 Controller, HP Smart Array P212 Controller, HP Smart Array P400 Controller, HP Smart Array P410 Controller, HP Smart Array P411 Controller, HP Smart Array P700m Controller, HP Smart Array P800 Controller
Operating Systems Affected: Not Applicable
Software Affected: Not Applicable
Support Communication Cross Reference ID: IA01686968
©Copyright 2009 Hewlett-Packard Development Company, L.P.
Hewlett-Packard Company shall not be liable for technical or editorial errors or omissions contained herein. The information provided is provided "as is" without warranty of any kind. To the extent permitted by law, neither HP or its affiliates, subcontractors or suppliers will be liable for incidental,special or consequential damages including downtime cost; lost profits;damages relating to the procurement of substitute products or services; or damages for loss of data, or software restoration. The information in this document is subject to change without notice. Hewlett-Packard Company and the names of Hewlett-Packard products referenced herein are trademarks of Hewlett-Packard Company in the United States and other countries. Other product and company names mentioned herein may be trademarks of their respective owners.

Provide feedback

Please rate the information on this page to help us improve our content. Thank you!