Print | Rate this content

HPSBMA02491 SSRT100060 rev.1 - HP Operations Manager for Windows, Remote Execution of Arbitrary Code

SUPPORT COMMUNICATION - SECURITY BULLETIN

Document ID: c02078800

Version: 1

HPSBMA02491 SSRT100060 rev.1 - HP Operations Manager for Windows, Remote Execution of Arbitrary Code
NOTICE: The information in this Security Bulletin should be acted upon as soon as possible.

Release Date: 2010-04-19

Last Updated: 2010-04-19


Potential Security Impact: Remote execution of arbitrary code

Source: Hewlett-Packard Company, HP Software Security Response Team

VULNERABILITY SUMMARY

A potential security vulnerability has been identified with HP Operations Manager for Windows. The vulnerability could be exploited remotely to allow execution of arbitrary code.

References: CVE-2010-1033

SUPPORTED SOFTWARE VERSIONS*: ONLY impacted versions are listed.

HP Operations Manager for Windows v8.10, v8.16 with srcvw4.dll v4.0.1.1 and earlier
HP Operations Manager for Windows v7.5 with srcvw32.dll v2.23.28 and earlier

BACKGROUND

For a PGP signed version of this security bulletin please write to: security-alert@hp.com

CVSS 2.0 Base Metrics

Reference
Base Vector
Base Score
CVE-2010-1033
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
6.8

Information on CVSS is documented in HP Customer Notice: HPSN-2008-002.

The Hewlett-Packard Company thanks mr_me, a member of Corelan Team, for reporting this vulnerability to security-alert@hp.com.

RESOLUTION

HP has made a new version of srcvw4.dll available to resolve the vulnerability on Operations Manager for Windows v8.10 and v8.16.

HP has made a new version of srcvw32.dll available to resolve the vulnerability on Operations Manager for Windows v7.5.

Note: The appropriate new version, either srcvw4.dll or srcvw32.dll, must be installed on the Operations Manager for Windows management server and on all remote console systems.

For Operations Manager for Windows v8.10 and v8.16

Verify the version of srcvw4.dll currently installed

  1. Right-click on %OvInstallDir%\bin\srcvw4.dll
  2. Select “Properties”
  3. Switch to “details” tab
  4. Check “File version”
  5. v4.0.1.1 and earlier are vulnerable

Install required patch

The new version of srcvw4.dll (v4.0.1.2) requires OMW_00060, available here http://support.openview.hp.com/selfsolve/patches

Download the new version of srcvw4.dll

The new version is in the file OMW60_srcvw4.dll, available using ftp:

Host
Account
Password
ftp.usa.hp.com
sb02491
Secure12

Optionally verify the SHA-1 sum:
b48f-27e1-15c4-a7ab-d64e-ff65-caf3-543a-dece-16bd OMW60_srcvw4.dll

Install the new version of srcvw4.dl

  1. Stop the Operations Manager for Windows console and its additional binaries, such as node editor.
  2. From a command prompt, backup %OvInstallDir%\bin\srcvw4.dll
  3. From a command prompt, copy OMW60_srcvw4.dll into %OvInstallDir%\bin\srcvw4.dll
  4. Verify that %OvInstallDir%\bin\srcvw4.dll is now v4.0.1.2

Note: Steps 2 and 3 above must be performed from the Windows command line, not from Windows Explorer.

For Operations Manager for Windows v7.5

Verify the version of srcvw32.dll currently installed

  1. Right-click on %OvInstallDir%\bin\srcvw32.dll
  2. Select “Properties”
  3. Switch to “details” tab
  4. Check “File version”
  5. v2.23.28 and earlier are vulnerable

Install required patch

The new version of srcvw32.dll (v2.23.29 HP) requires OVOW_00279, available here http://support.openview.hp.com/selfsolve/patches

Download the new version of srcvw32.dll

The new version is in the file OVOW279_srcvw32.dll, available using ftp:

Host
Account
Password
ftp.usa.hp.com
sb02491
Secure12

Optionally verify the SHA-1 sum:
14e5-0530-2ec5-4b4a-3ceb-2e15-9491-6b6e-6ef6-6664 OVOW279_srcvw32.dll

Install the new version of srcvw32.dl

  1. Stop the Operations Manager for Windows console and its additional binaries, such as node editor.
  2. From a command prompt, backup %OvInstallDir%\bin\srcvw32.dll
  3. From a command prompt, copy OVOW279_srcvw32.dll into %OvInstallDir%\bin\srcvw32.dll
  4. Verify that %OvInstallDir%\bin\srcvw32.dll is now v2.23.29 HP

Note: Steps 2 and 3 above must be performed from the Windows command line, not from Windows Explorer.

PRODUCT SPECIFIC INFORMATION
None

HISTORY
Version:1 (rev.1) - 19 April 2010 Initial release

Third Party Security Patches: Third party security patches that are to be installed on systems running HP software products should be applied in accordance with the customer's patch management policy.

©Copyright 2010 Hewlett-Packard Development Company, L.P.
Hewlett-Packard Company shall not be liable for technical or editorial errors or omissions contained herein. The information provided is provided "as is" without warranty of any kind. To the extent permitted by law, neither HP or its affiliates, subcontractors or suppliers will be liable for incidental,special or consequential damages including downtime cost; lost profits;damages relating to the procurement of substitute products or services; or damages for loss of data, or software restoration. The information in this document is subject to change without notice. Hewlett-Packard Company and the names of Hewlett-Packard products referenced herein are trademarks of Hewlett-Packard Company in the United States and other countries. Other product and company names mentioned herein may be trademarks of their respective owners.

Provide feedback

Please rate the information on this page to help us improve our content. Thank you!