Print | Rate this content

HP 5830 Switch Series - BGP Configuration: BGP Configuration Examples

BGP basic configuration

Network requirements:

In Figure 1, run eBGP between Switch A and Switch B and iBGP between Switch B and Switch C so that Switch C can access the network 8.1.1.0/24 connected to Router A.

Figure 1: Network diagram for BGP basic configuration

Procedure:

  1. Configure IP addresses for interfaces (omitted).

  2. Configure iBGP.

    • To prevent route flapping caused by port state changes, this example uses loopback interfaces to establish iBGP connections.

    • Because loopback interfaces are virtual interfaces, the user needs to use the peer connect-interface command to specify the loopback interface as the source interface for establishing BGP connections.

    • Enable OSPF in AS 65009 to ensure that Switch B can communicate with Switch C through loopback interfaces.

    Configure Switch B:

    <SwitchB> system-view
    [SwitchB] bgp 65009
    [SwitchB-bgp] router-id 2.2.2.2
    [SwitchB-bgp] peer 3.3.3.3 as-number 65009
    [SwitchB-bgp] peer 3.3.3.3 connect-interface loopback 0
    [SwitchB-bgp] quit
    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [SwitchB-ospf-1-area-0.0.0.0] network 9.1.1.1 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    Configure Switch C:

    <SwitchC> system-view
    [SwitchC] bgp 65009
    [SwitchC-bgp] router-id 3.3.3.3
    [SwitchC-bgp] peer 2.2.2.2 as-number 65009
    [SwitchC-bgp] peer 2.2.2.2 connect-interface loopback 0
    [SwitchC-bgp] quit
    [SwitchC] ospf 1
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [SwitchC-ospf-1-area-0.0.0.0] network 9.1.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit
    [SwitchC] display bgp peer

    BGP local router ID : 3.3.3.3
    Local AS number : 65009
    Total number of peers : 1 Peers in established state : 1


    Peer AS MsgRcvd MsgSent OutQ PrefRcv Up/Down State


    2.2.2.2 65009 2 2 0 0 00:00:13 Established

    The output information shows that Switch C has established an iBGP peer relationship with Switch B.

  3. Configure eBGP.

    • The eBGP peers, Switch A and Switch B (usually belong to different carriers), are located in different ASs. Generally, loopback interfaces are not reachable to each other, so directly connected interfaces are used for establishing BGP sessions.

    • To enable Switch C to access the network 8.1.1.0/24 connected directly to Switch A, inject network 8.1.1.0/24 to the BGP routing table of Switch A.

    Configure Switch A:

    <SwitchA> system-view
    [SwitchA] bgp 65008
    [SwitchA-bgp] router-id 1.1.1.1
    [SwitchA-bgp] peer 3.1.1.1 as-number 65009
    [SwitchA-bgp] network 8.1.1.1 24
    [SwitchA-bgp] quit

    Configure Switch B:

    [SwitchB] bgp 65009
    [SwitchB-bgp] peer 3.1.1.2 as-number 65008
    [SwitchB-bgp] quit

    Display BGP peer information on Switch B:

    [SwitchB] display bgp peer


    BGP local router ID : 2.2.2.2
    Local AS number : 65009
    Total number of peers : 2 Peers in established state : 2


    Peer AS MsgRcvd MsgSent OutQ PrefRcv Up/Down State


    3.3.3.3 65009 4 4 0 0 00:02:49 Established
    3.1.1.2 65008 2 2 0 0 00:00:05 Established

    The output shows that Switch B has established an iBGP peer relationship with Switch C and an eBGP peer relationship with Switch A.

    Display the BGP routing table on Switch A:

    [SwitchA] display bgp routing-table


    Total Number of Routes: 1


    BGP Local router ID is 1.1.1.1
    Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
    h - history, I - internal, s - suppressed, S - Stale
    Origin : I - IGP, e - EGP, ? - incomplete


    Network NextHop MED LocPrf PrefVal Path/Ogn


    *> 8.1.1.0/24 0.0.0.0 0 0 I

    Display the BGP routing table on Switch B:

    [SwitchB] display bgp routing-table


    Total Number of Routes: 1


    BGP Local router ID is 2.2.2.2
    Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
    h - history, I - internal, s - suppressed, S - Stale
    Origin : I - IGP, e - EGP, ? - incomplete


    Network NextHop MED LocPrf PrefVal Path/Ogn


    *> 8.1.1.0/24 3.1.1.2 0 0 65008i

    Display the BGP routing table on Switch C:

    [SwitchC] display bgp routing-table


    Total Number of Routes: 1


    BGP Local router ID is 3.3.3.3

    Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
    h - history, I - internal, s - suppressed, S - Stale
    Origin : I - IGP, e - EGP, ? - incomplete


    Network NextHop MED LocPrf PrefVal Path/Ogn


    I 8.1.1.0/24 3.1.1.2 0 100 0 65008i

    From the above outputs, the user can find Switch A has learned no route to AS65009, and Switch C has learned network 8.1.1.0 but the next hop 3.1.1.2 is unreachable, so the route is invalid.

  4. Redistribute direct routes.

    Configure BGP to redistribute direct routes on Switch B, so that Switch A can obtain the route to 9.1.1.0/24 and Switch C can obtain the route to 3.1.1.0/24.

    Configure Switch B:

    [SwitchB] bgp 65009
    [SwitchB-bgp] import-route direct

    Display the BGP routing table on Switch A:

    [SwitchA] display bgp routing-table


    Total Number of Routes: 4


    BGP Local router ID is 1.1.1.1
    Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
    h - history, I - internal, s - suppressed, S - Stale
    Origin : I - IGP, e - EGP, ? – incomplete


    Network NextHop MED LocPrf PrefVal Path/Ogn


    *> 2.2.2.2/32 3.1.1.1 0 0 65009?
    * 3.1.1.0/24 3.1.1.1 0 0 65009?
    *> 8.1.1.0/24 0.0.0.0 0 0 I
    *> 9.1.1.0/24 3.1.1.1 0 0 65009?

    Two routes 2.2.2.2/32 and 9.1.1.0/24 have been added in Switch A routing table.

    Display the BGP routing table on Switch C:

    [SwitchC] display bgp routing-table


    Total Number of Routes: 4


    BGP Local router ID is 3.3.3.3
    Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
    h - history, I - internal, s - suppressed, S - Stale
    Origin : I - IGP, e - EGP, ? - incomplete


    Network NextHop MED LocPrf PrefVal Path/Ogn


    I 2.2.2.2/32 2.2.2.2 0 100 0 ?
    *>I 3.1.1.0/24 2.2.2.2 0 100 0 ?
    *>I 8.1.1.0/24 3.1.1.2 0 100 0 65008i
    * I 9.1.1.0/24 2.2.2.2 0 100 0 ?

    The output shows that the route 8.1.1.0 becomes valid with the next hop as Switch A.

  5. Verify the configuration.

    Ping 8.1.1.1 on Switch C:

    [SwitchC] ping 8.1.1.1
    PING 8.1.1.1: 56 data bytes, press CTRL_C to break
    Reply from 8.1.1.1: bytes=56 Sequence=1 ttl=254 time=2 ms
    Reply from 8.1.1.1: bytes=56 Sequence=2 ttl=254 time=2 ms
    Reply from 8.1.1.1: bytes=56 Sequence=3 ttl=254 time=2 ms
    Reply from 8.1.1.1: bytes=56 Sequence=4 ttl=254 time=2 ms
    Reply from 8.1.1.1: bytes=56 Sequence=5 ttl=254 time=2 ms
    --- 8.1.1.1 ping statistics —
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 2/2/2 ms

top

BGP and IGP synchronization configuration

Network requirements:

As shown in Figure 2, all devices of company A belong to AS 65008, and all devices of company B belong to AS 65009. AS 65008 and AS 65009 are connected through Switch A and Switch B. Switch A must be able to access network 9.1.2.0/24 in AS 65009, and Switch C must access network 8.1.1.0/24 in AS 65008.

Figure 2: Network diagram for BGP and IGP synchronization

Procedure:

  1. Configure IP addresses for interfaces (omitted).

  2. Configure OSPF.

    Enable OSPF in AS 65009, so that Switch B can obtain the route to 9.1.2.0/24.

    Configure Switch B:

    <SwitchB> system-view
    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [SwitchB-ospf-1-area-0.0.0.0] network 9.1.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    Configure Switch C:

    <SwitchC> system-view
    [SwitchC] ospf 1
    [SwitchC-ospf-1] import-route direct
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 9.1.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

  3. Configure the eBGP connection.

    Configure the eBGP connection and inject network 8.1.1.0/24 to the BGP routing table of Switch A, so that Switch B can obtain the route to 8.1.1.0/24.

    Configure Switch A:

    <SwitchA> system-view
    [SwitchA] bgp 65008
    [SwitchA-bgp] router-id 1.1.1.1
    [SwitchA-bgp] peer 3.1.1.1 as-number 65009
    [SwitchA-bgp] network 8.1.1.0 24
    [SwitchA-bgp] quit

    Configure Switch B:

    [SwitchB] bgp 65009
    [SwitchB-bgp] router-id 2.2.2.2
    [SwitchB-bgp] peer 3.1.1.2 as-number 65008

  4. Configure BGP and IGP synchronization.

    • Configure BGP to redistribute routes from OSPF on Switch B, so that Switch A can obtain the route to 9.1.2.0/24.

    • Configure OSPF to redistribute routes from BGP on Switch B, so that Switch C can obtain the route to 8.1.1.0/24.

    Configure BGP to redistribute routes from OSPF on Switch B:

    [SwitchB-bgp] import-route ospf 1
    [SwitchB-bgp] quit
    [SwitchB] ospf 1
    [SwitchB-ospf-1] import-route bgp
    [SwitchB-ospf-1] quit

    Display the BGP routing table on Switch A:

    [SwitchA] display bgp routing-table


    Total Number of Routes: 3


    BGP Local router ID is 1.1.1.1
    Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,

    h - history, I - internal, s - suppressed, S - Stale
    Origin : I - IGP, e - EGP, ? - incomplete


    Network NextHop MED LocPrf PrefVal Path/Ogn


    *> 3.3.3.3/32 3.1.1.1 1 0 65009?
    *> 8.1.1.0/24 0.0.0.0 0 0 I
    *> 9.1.2.0/24 3.1.1.1 1 0 65009?

    Display the routing table on Switch C:

    [SwitchC] display ip routing-table
    Routing Tables: Public
    Destinations : 9 Routes : 9


    Destination/Mask Proto Pre Cost NextHop Interface


    2.2.2.2/32 OSPF 10 1 9.1.1.1 Vlan300
    3.3.3.3/32 Direct 0 0 127.0.0.1 InLoop0
    8.1.1.0/24 O_ASE 150 1 9.1.1.1 Vlan300
    9.1.1.0/24 Direct 0 0 9.1.1.2 Vlan300
    9.1.1.2/32 Direct 0 0 127.0.0.1 InLoop0
    9.1.2.0/24 Direct 0 0 9.1.2.1 Vlan400
    9.1.2.1/32 Direct 0 0 127.0.0.1 InLoop0
    127.0.0.0/8 Direct 0 0 127.0.0.1 InLoop0
    127.0.0.1/32 Direct 0 0 127.0.0.1 InLoop0

  5. Verify the configuration.

    Use ping for verification:

    [SwitchA] ping -a 8.1.1.1 9.1.2.1
    PING 9.1.2.1: 56 data bytes, press CTRL_C to break
    Reply from 9.1.2.1: bytes=56 Sequence=1 ttl=254 time=15 ms
    Reply from 9.1.2.1: bytes=56 Sequence=2 ttl=254 time=31 ms
    Reply from 9.1.2.1: bytes=56 Sequence=3 ttl=254 time=47 ms
    Reply from 9.1.2.1: bytes=56 Sequence=4 ttl=254 time=46 ms
    Reply from 9.1.2.1: bytes=56 Sequence=5 ttl=254 time=47 ms

    --- 9.1.2.1 ping statistics —
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 15/37/47 ms
    [SwitchC] ping -a 9.1.2.1 8.1.1.1
    PING 8.1.1.1: 56 data bytes, press CTRL_C to break
    Reply from 8.1.1.1: bytes=56 Sequence=1 ttl=254 time=2 ms
    Reply from 8.1.1.1: bytes=56 Sequence=2 ttl=254 time=2 ms
    Reply from 8.1.1.1: bytes=56 Sequence=3 ttl=254 time=2 ms
    Reply from 8.1.1.1: bytes=56 Sequence=4 ttl=254 time=2 ms
    Reply from 8.1.1.1: bytes=56 Sequence=5 ttl=254 time=2 ms

    --- 8.1.1.1 ping statistics -
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 2/2/2 ms

top

BGP load balancing configuration

Network requirements:

As shown in Figure 3, all the switches run BGP. Switch A resides in AS 65008, Switch B and Switch C in AS 65009. Between Switch A and Switch B, Switch A and Switch C are eBGP connections, and between Switch B and Switch C is an iBGP connection. Two routes are configured on Switch A for load balancing.

Figure 3: Network diagram for BGP load balancing configuration

Procedure:

  1. Configure IP addresses for interfaces (omitted).

  2. Configure BGP connections.

    • On Switch A, establish eBGP connections with Switch B and Switch C respectively; configure BGP to advertise network 8.1.1.0/24 to Switch B and Switch C, so that Switch B and Switch C can access the internal network connected to Switch A.

    • On Switch B, establish an eBGP connection with Switch A and an iBGP connection with Switch C; configure BGP to advertise network 9.1.1.0/24 to Switch A, so that Switch A can access the intranet through Switch B; configure a static route to interface loopback 0 on Switch C (or use a routing protocol like OSPF) to establish the iBGP connection.

    • On Switch C, establish an eBGP connection with Switch A and an iBGP connection with Switch B; configure BGP to advertise network 9.1.1.0/24 to Switch A, so that Switch A can access the intranet through Switch C; configure a static route to interface loopback 0 on Switch B (or use another protocol like OSPF) to establish the iBGP connection.

      Configure Switch A:

      <SwitchA> system-view
      [SwitchA] bgp 65008
      [SwitchA-bgp] router-id 1.1.1.1
      [SwitchA-bgp] peer 3.1.1.1 as-number 65009
      [SwitchA-bgp] peer 3.1.2.1 as-number 65009
      [SwitchA-bgp] network 8.1.1.1 24
      [SwitchA-bgp] quit

      Configure Switch B:

      <SwitchB> system-view
      [SwitchB] bgp 65009
      [SwitchB-bgp] router-id 2.2.2.2
      [SwitchB-bgp] peer 3.1.1.2 as-number 65008
      [SwitchB-bgp] peer 3.3.3.3 as-number 65009
      [SwitchB-bgp] peer 3.3.3.3 connect-interface loopback 0
      [SwitchB-bgp] network 9.1.1.0 255.255.255.0
      [SwitchB-bgp] quit
      [SwitchB] ip route-static 3.3.3.3 32 9.1.1.2

      Configure Switch C:

      <SwitchC> system-view
      [SwitchC] bgp 65009
      [SwitchC-bgp] router-id 3.3.3.3
      [SwitchC-bgp] peer 3.1.2.2 as-number 65008
      [SwitchC-bgp] peer 2.2.2.2 as-number 65009
      [SwitchC-bgp] peer 2.2.2.2 connect-interface loopback 0
      [SwitchC-bgp] network 9.1.1.0 255.255.255.0
      [SwitchC-bgp] quit
      [SwitchC] ip route-static 2.2.2.2 32 9.1.1.1

      Display the BGP routing table on Switch A:

      [SwitchA] display bgp routing-table


      Total Number of Routes: 3


      BGP Local router ID is 1.1.1.1
      Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
      h - history, I - internal, s - suppressed, S - Stale
      Origin : I - IGP, e - EGP, ? – incomplete


      Network NextHop MED LocPrf PrefVal Path/Ogn


      *> 8.1.1.0/24 0.0.0.0 0 0 I
      *> 9.1.1.0/24 3.1.1.1 0 0 65009i
      * 3.1.2.1 0 0 65009i

    • The output shows two valid routes to destination 9.1.1.0/24: the route with next hop 3.1.1.1 is marked with a greater-than sign (>), indicating it is the best route (because the ID of Switch B is smaller); the route with next hop 3.1.2.1 is marked with only an asterisk (*), indicating it is a valid route, but not the best.

    • Using the display ip routing-table command, the user can find only one route to 9.1.1.0/24 with next hop 3.1.1.1 and outbound interface VLAN-interface 200.

  3. Configure loading balancing.

    Since Switch A has two routes to reach AS 65009, configuring load balancing over the two BGP routes on Switch A can improve link utilization.

    Configure Switch A:

    [SwitchA] bgp 65008
    [SwitchA-bgp] balance 2
    [SwitchA-bgp] quit

  4. Verify the configuration.

    Display the BGP routing table on Switch A:

    [SwitchA] display bgp routing-table


    Total Number of Routes: 3


    BGP Local router ID is 1.1.1.1
    Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
    h - history, I - internal, s - suppressed, S - Stale
    Origin : I - IGP, e - EGP, ? - incomplete
    Network NextHop MED LocPrf PrefVal Path/Ogn


    *> 8.1.1.0/24 0.0.0.0 0 0 I
    *> 9.1.1.0/24 3.1.1.1 0 0 65009i
    *> 3.1.2.1 0 0 65009i

    • The route 9.1.1.0/24 has two next hops 3.1.1.1 and 3.1.2.1, both of which are marked with a greater-than sign (>), indicating they are the best routes.

    • Using the display ip routing-table command, the user can find two routes to 9.1.1.0/24: one with next hop 3.1.1.1 and outbound interface VLAN-interface 200, the other with next hop 3.1.2.1 and outbound interface VLAN-interface 300.

top

BGP community configuration

Network requirements:

As shown in Figure 4, Switch B establishes eBGP connections with Switch A and C. Configure No_Export community attribute on Switch A to make routes from AS 10 not advertised by AS 20 to any other AS.

Figure 4: Network diagram for BGP community configuration

Procedure:

  1. Configure IP addresses for interfaces (omitted).

  2. Configure eBGP.

    Configure Switch A:

    <SwitchA> system-view
    [SwitchA] bgp 10
    [SwitchA-bgp] router-id 1.1.1.1
    [SwitchA-bgp] peer 200.1.2.2 as-number 20
    [SwitchA-bgp] network 9.1.1.0 255.255.255.0
    [SwitchA-bgp] quit

    Configure Switch B:

    <SwitchB> system-view
    [SwitchB] bgp 20
    [SwitchB-bgp] router-id 2.2.2.2
    [SwitchB-bgp] peer 200.1.2.1 as-number 10
    [SwitchB-bgp] peer 200.1.3.2 as-number 30
    [SwitchB-bgp] quit

    Configure Switch C:

    <SwitchC> system-view
    [SwitchC] bgp 30
    [SwitchC-bgp] router-id 3.3.3.3
    [SwitchC-bgp] peer 200.1.3.1 as-number 20
    [SwitchC-bgp] quit

    Display the BGP routing table on Switch B:

    [SwitchB] display bgp routing-table 9.1.1.0


    BGP local router ID : 2.2.2.2
    Local AS number : 20
    Paths: 1 available, 1 best

    BGP routing table entry information of 9.1.1.0/24:
    From : 200.1.2.1 (1.1.1.1)

    Original nexthop: 200.1.2.1
    AS-path : 10
    Origin : igp
    Attribute value : MED 0, pref-val 0, pre 255
    State : valid, external, best,
    Advertised to such 1 peers:
    200.1.3.2

    Switch B advertised routes to Switch C in AS30.

    Display the routing table on Switch C:

    [SwitchC] display bgp routing-table


    Total Number of Routes: 1


    BGP Local router ID is 3.3.3.3
    Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
    h - history, I - internal, s - suppressed, S - Stale
    Origin : I - IGP, e - EGP, ? - incomplete
    Network NextHop MED LocPrf PrefVal Path/Ogn


    *> 9.1.1.0/24 200.1.3.1 0 0 20 10i

    Switch C has learned route 9.1.1.0/24 from Switch B.

  3. Configure BGP community.

    Configure a routing policy:

    [SwitchA] route-policy comm_policy permit node 0
    [SwitchA-route-policy] apply community no-export
    [SwitchA-route-policy] quit

    Apply the routing policy:

    [SwitchA] bgp 10
    [SwitchA-bgp] peer 200.1.2.2 route-policy comm_policy export
    [SwitchA-bgp] peer 200.1.2.2 advertise-community

    Display the routing table on Switch B:

    [SwitchB] display bgp routing-table 9.1.1.0
    BGP local router ID : 2.2.2.2
    Local AS number : 20
    Paths: 1 available, 1 best


    BGP routing table entry information of 9.1.1.0/24:
    From : 200.1.2.1 (1.1.1.1)
    Original nexthop: 200.1.2.1
    Community : No-Export
    AS-path : 10
    Origin : igp
    Attribute value : MED 0, pref-val 0, pre 255
    State : valid, external, best,
    Not advertised to any peers yet

    The route 9.1.1.0/24 is not available in the routing table of Switch C.

top

BGP route reflector configuration

Network requirements:

In Figure 5, all switches run BGP.

  • Between Switch A and Switch B is an eBGP connection, between Switch C and Switch B, and between Switch C and Switch D are iBGP connections.

  • Switch C is a route reflector with clients Switch B and D.

  • Switch D can learn route 1.0.0.0/8 from Switch C.

Figure 5: Network diagram for BGP route reflector configuration

Procedure:

  1. Configure IP addresses for interfaces (omitted).

  2. Configure BGP connections.

    Configure Switch A:

    <SwitchA> system-view
    [SwitchA] bgp 100
    [SwitchA-bgp] router-id 1.1.1.1
    [SwitchA-bgp] peer 192.1.1.2 as-number 200

    Inject network 1.0.0.0/8 to the BGP routing table:

    [SwitchA-bgp] network 1.0.0.0
    [SwitchA-bgp] quit

    Configure Switch B:

    <SwitchB> system-view
    [SwitchB] bgp 200
    [SwitchB-bgp] router-id 2.2.2.2
    [SwitchB-bgp] peer 192.1.1.1 as-number 100
    [SwitchB-bgp] peer 193.1.1.1 as-number 200
    [SwitchB-bgp] peer 193.1.1.1 next-hop-local
    [SwitchB-bgp] quit

    Configure Switch C:

    <SwitchC> system-view
    [SwitchC] bgp 200
    [SwitchC-bgp] router-id 3.3.3.3
    [SwitchC-bgp] peer 193.1.1.2 as-number 200
    [SwitchC-bgp] peer 194.1.1.2 as-number 200
    [SwitchC-bgp] quit

    Configure Switch D:

    <SwitchD> system-view
    [SwitchD] bgp 200
    [SwitchD-bgp] router-id 4.4.4.4
    [SwitchD-bgp] peer 194.1.1.1 as-number 200
    [SwitchD-bgp] quit

  3. Configure the route reflector.

    Configure Switch C:

    [SwitchC] bgp 200
    [SwitchC-bgp] peer 193.1.1.2 reflect-client
    [SwitchC-bgp] peer 194.1.1.2 reflect-client
    [SwitchC-bgp] quit

  4. Verify the configuration.

    Display the BGP routing table on Switch B:

    [SwitchB] display bgp routing-table

    Total Number of Routes: 1

    BGP Local router ID is 200.1.2.2
    Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
    h - history, i - internal, s - suppressed, S - Stale
    Origin : i - IGP, e - EGP, ? - incomplete
    Network NextHop MED LocPrf PrefVal Path/Ogn

    *> 1.0.0.0 192.1.1.1 0 0 100i

    Display the BGP routing table on Switch D:

    [SwitchD] display bgp routing-table

    Total Number of Routes: 1

    BGP Local router ID is 200.1.2.1
    Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
    h - history, i - internal, s - suppressed, S - Stale
    Origin : i - IGP, e - EGP, ? - incomplete
    Network NextHop MED LocPrf PrefVal Path/Ogn

    I 1.0.0.0 193.1.1.2 0 100 0 100i

    Switch D has learned route 1.0.0.0/8 from Switch C.

top

BGP confederation configuration

Network requirements:

As shown in Figure 6, to reduce iBGP connections in AS 200, split it into three sub-ASs, AS65001, AS65002 and AS65003. Switches in AS65001 are fully meshed.

Figure 6: Network diagram for BGP confederation configuration

Procedure:

  1. Configure IP addresses for interfaces (omitted).

  2. Configure BGP confederation.

    Configure Switch A:

    <SwitchA> system-view
    [SwitchA] bgp 65001
    [SwitchA-bgp] router-id 1.1.1.1
    [SwitchA-bgp] confederation id 200
    [SwitchA-bgp] confederation peer-as 65002 65003
    [SwitchA-bgp] peer 10.1.1.2 as-number 65002
    [SwitchA-bgp] peer 10.1.1.2 next-hop-local
    [SwitchA-bgp] peer 10.1.2.2 as-number 65003
    [SwitchA-bgp] peer 10.1.2.2 next-hop-local
    [SwitchA-bgp] quit

    Configure Switch B:

    <SwitchB> system-view
    [SwitchB] bgp 65002
    [SwitchB-bgp] router-id 2.2.2.2
    [SwitchB-bgp] confederation id 200
    [SwitchB-bgp] confederation peer-as 65001 65003
    [SwitchB-bgp] peer 10.1.1.1 as-number 65001
    [SwitchB-bgp] quit

    Configure Switch C:

    <SwitchC> system-view
    [SwitchC] bgp 65003
    [SwitchC-bgp] router-id 3.3.3.3
    [SwitchC-bgp] confederation id 200
    [SwitchC-bgp] confederation peer-as 65001 65002
    [SwitchC-bgp] peer 10.1.2.1 as-number 65001
    [SwitchC-bgp] quit

  3. Configure iBGP connections in AS65001.

    Configure Switch A:

    [SwitchA] bgp 65001
    [SwitchA-bgp] peer 10.1.3.2 as-number 65001
    [SwitchA-bgp] peer 10.1.3.2 next-hop-local
    [SwitchA-bgp] peer 10.1.4.2 as-number 65001
    [SwitchA-bgp] peer 10.1.4.2 next-hop-local
    [SwitchA-bgp] quit

    Configure Switch D:

    <SwitchD> system-view
    [SwitchD] bgp 65001
    [SwitchD-bgp] router-id 4.4.4.4
    [SwitchD-bgp] confederation id 200
    [SwitchD-bgp] peer 10.1.3.1 as-number 65001
    [SwitchD-bgp] peer 10.1.5.2 as-number 65001
    [SwitchD-bgp] quit

    Configure Switch E:

    <SwitchE> system-view
    [SwitchE] bgp 65001
    [SwitchE-bgp] router-id 5.5.5.5
    [SwitchE-bgp] confederation id 200
    [SwitchE-bgp] peer 10.1.4.1 as-number 65001
    [SwitchE-bgp] peer 10.1.5.1 as-number 65001
    [SwitchE-bgp] quit

  4. Configure the eBGP connection between AS100 and AS200.

    Configure Switch A:

    [SwitchA] bgp 65001
    [SwitchA-bgp] peer 200.1.1.2 as-number 100
    [SwitchA-bgp] quit

    Configure Switch F:

    <SwitchF> system-view
    [SwitchF] bgp 100
    [SwitchF-bgp] router-id 6.6.6.6
    [SwitchF-bgp] peer 200.1.1.1 as-number 200
    [SwitchF-bgp] network 9.1.1.0 255.255.255.0
    [SwitchF-bgp] quit

  5. Verify the configuration.

    Display the routing table on Switch B:

    [SwitchB] display bgp routing-table

    Total Number of Routes: 1

    BGP Local router ID is 2.2.2.2
    Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
    h - history, i - internal, s - suppressed, S - Stale
    Origin : i - IGP, e - EGP, ? - incomplete
    Network NextHop MED LocPrf PrefVal Path/Ogn

    *>i 9.1.1.0/24 10.1.1.1 0 100 0 (65001) 100i
    [SwitchB] display bgp routing-table 9.1.1.0

    BGP local router ID : 2.2.2.2
    Local AS number : 65002
    Paths: 1 available, 1 best

    BGP routing table entry information of 9.1.1.0/24:
    From : 10.1.1.1 (1.1.1.1)
    Relay Nexthop : 0.0.0.0
    Original nexthop: 10.1.1.1
    AS-path : (65001) 100
    Origin : igp
    Attribute value : MED 0, localpref 100, pref-val 0, pre 255
    State : valid, external-confed, best,
    Not advertised to any peers yet

    Display the BGP routing table on Switch D:

    [SwitchD] display bgp routing-table

    Total Number of Routes: 1

    BGP Local router ID is 4.4.4.4
    Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
    h - history, i - internal, s - suppressed, S - Stale
    Origin : i - IGP, e - EGP, ? - incomplete
    Network NextHop MED LocPrf PrefVal Path/Ogn

    *>i 9.1.1.0/24 10.1.3.1 0 100 0 100i
    [SwitchD] display bgp routing-table 9.1.1.0

    BGP local router ID : 4.4.4.4
    Local AS number : 65001
    Paths: 1 available, 1 best

    BGP routing table entry information of 9.1.1.0/24:
    From : 10.1.3.1 (1.1.1.1)
    Relay Nexthop : 0.0.0.0
    Original nexthop: 10.1.3.1
    AS-path : 100
    Origin : igp
    Attribute value : MED 0, localpref 100, pref-val 0, pre 255
    State : valid, internal, best,
    Not advertised to any peers yet

    The output information shows that:

    • Switch F can send route information to Switch B and Switch C through the confederation by establishing only an eBGP connection with Switch A.

    • Switch B and Switch D are in the same confederation, but belong to different sub ASs. They obtain external route information from Switch A and gene rate the same BGP route entries; it seems like that they reside in the same AS although they have no direct connection in between.

top

BGP path selection configuration

Network requirements:

  • In Figure 7, all switches run BGP. Between Switch A and Switch B, and between Switch A and Switch C are eBGP connections. Between Switch B and Switch D, and between Switch D and Switch C are iBGP connections.

  • OSPF is the IGP protocol in AS 200.

  • Configure routing policies, making Switch D use the route 1.0.0.0/8 from Switch C as the optimal.

Figure 7: Network diagram for BGP path selection configuration

Procedure:

  1. Configure IP addresses for interfaces (omitted).

  2. Configure OSPF on Switch B, C, and D.

    Configure Switch B:

    <SwitchB> system-view
    [SwitchB] ospf
    [SwitchB-ospf] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 192.1.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 194.1.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    Configure Switch C:

    <SwitchC> system-view
    [SwitchC] ospf
    [SwitchC-ospf] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 193.1.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 195.1.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

    Configure Switch D:

    <SwitchD> system-view
    [SwitchD] ospf
    [SwitchD-ospf] area 0
    [SwitchD-ospf-1-area-0.0.0.0] network 194.1.1.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] network 195.1.1.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] quit
    [SwitchD-ospf-1] quit

  3. Configure BGP connections.

    Configure Switch A:

    <SwitchA> system-view
    [SwitchA] bgp 100
    [SwitchA-bgp] peer 192.1.1.2 as-number 200
    [SwitchA-bgp] peer 193.1.1.2 as-number 200

    Inject network 1.0.0.0/8 to the BGP routing table on Switch A:

    [SwitchA-bgp] network 1.0.0.0 8
    [SwitchA-bgp] quit

    Configure Switch B:

    [SwitchB] bgp 200
    [SwitchB-bgp] peer 192.1.1.1 as-number 100
    [SwitchB-bgp] peer 194.1.1.1 as-number 200
    [SwitchB-bgp] quit

    Configure Switch C:

    [SwitchC] bgp 200
    [SwitchC-bgp] peer 193.1.1.1 as-number 100
    [SwitchC-bgp] peer 195.1.1.1 as-number 200
    [SwitchC-bgp] quit

    Configure Switch D:

    [SwitchD] bgp 200
    [SwitchD-bgp] peer 194.1.1.2 as-number 200
    [SwitchD-bgp] peer 195.1.1.2 as-number 200
    [SwitchD-bgp] quit

  4. Configure attributes for route 1.0.0.0/8, making Switch D give priority to the route learned from Switch C.

    • Method I: Configure a higher MED value for the route 1.0.0.0/8 advertised from Switch A to peer 192.1.1.2.

      Define an ACL numbered 2000 to permit route 1.0.0.0/8:

      [SwitchA] acl number 2000
      [SwitchA-acl-basic-2000] rule permit source 1.0.0.0 0.255.255.255
      [SwitchA-acl-basic-2000] quit

      Define two routing policies, apply_med_50, which sets the MED for route 1.0.0.0/8 to 50, and apply_med_100, which sets the MED for route 1.0.0.0/8 to 100:

      [SwitchA] route-policy apply_med_50 permit node 10
      [SwitchA-route-policy] if-match acl 2000
      [SwitchA-route-policy] apply cost 50
      [SwitchA-route-policy] quit
      [SwitchA] route-policy apply_med_100 permit node 10
      [SwitchA-route-policy] if-match acl 2000
      [SwitchA-route-policy] apply cost 100
      [SwitchA-route-policy] quit

      Apply routing policy apply_med_50 to the route advertised to peer 193.1.1.2 (Switch C), and apply_med_100 to the route advertised to peer 192.1.1.2 (Switch B):

      [SwitchA] bgp 100
      [SwitchA-bgp] peer 193.1.1.2 route-policy apply_med_50 export
      [SwitchA-bgp] peer 192.1.1.2 route-policy apply_med_100 export
      [SwitchA-bgp] quit

      Display the BGP routing table on Switch D:

      x[SwitchD] display bgp routing-table

      Total Number of Routes: 2

      BGP Local router ID is 194.1.1.1
      Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
      h - history, i - internal, s - suppressed, S - Stale
      Origin : i - IGP, e - EGP, ? - incomplete
      Network NextHop MED LocPrf PrefVal Path/Ogn

      *>i 1.0.0.0 193.1.1.1 50 100 0 100i
      * i 192.1.1.1 100 100 0 100i

      Route 1.0.0.0/8 is the optimal.

    • Method II: Configure different local preferences on Switch B and C for route 1.0.0.0/8, making Switch D give priority to the route from Switch C.

      Define an ACL numbered 2000 on Router C, permitting route 1.0.0.0/8:

      [SwitchC] acl number 2000
      [SwitchC-acl-basic-2000] rule permit source 1.0.0.0 0.255.255.255
      [SwitchC-acl-basic-2000] quit

      Configure a routing policy named localpref on Switch C, setting the local preference of route 1.0.0.0/8 to 200 (the default is 100):

      [SwitchC] route-policy localpref permit node 10
      [SwitchC-route-policy] if-match acl 2000
      [SwitchC-route-policy] apply local-preference 200
      [SwitchC-route-policy] quit

      Apply routing policy localpref to routes from peer 193.1.1.1:

      [SwitchC] bgp 200
      [SwitchC-bgp] peer 193.1.1.1 route-policy localpref import
      [SwitchC-bgp] quit

      Display the routing table on Switch D:

      [SwitchD] display bgp routing-table

      Total Number of Routes: 2

      BGP Local router ID is 194.1.1.1
      Status codes: * - valid, ^ - VPNv4 best, > - best, d - damped,
      h - history, i - internal, s - suppressed, S - Stale
      Origin : i - IGP, e - EGP, ? - incomplete
      Network NextHop MED LocPrf PrefVal Path/Ogn

      *>i 1.0.0.0 193.1.1.1 0 200 0 100i
      * i 192.1.1.1 0 100 0 100i

      Route 1.0.0.0/8 from Switch D to Switch C is the optimal.

top

BGP GR configuration

Network requirements:

All switches run BGP in Figure 8. Between Switch A and Switch B is an eBGP connection. Switch B and Switch C are connected over an iBGP connection. Enable GR capability for BGP so that the communication between Switch A and Switch C is not affected when a Master/Subordinate switchover occurs on IRF device Switch B.

Figure 8: Network diagram for BGP GR configuration

Procedure:

  1. Configure Switch A.

    Configure IP addresses for interfaces (omitted).

    Configure the eBGP connection:

    <SwitchA> system-view
    [SwitchA] bgp 65008
    [SwitchA-bgp] router-id 1.1.1.1
    [SwitchA-bgp] peer 200.1.1.1 as-number 65009

    Inject network 8.0.0.0/8 to the BGP routing table:

    [SwitchA-bgp] network 8.0.0.0

    Enable GR capability for BGP:

    [SwitchA-bgp] graceful-restart

  2. Configure Switch B.

    Configure IP addresses for interfaces (omitted).

    Configure the eBGP connection:

    <SwitchB> system-view
    [SwitchB] bgp 65009
    [SwitchB-bgp] router-id 2.2.2.2
    [SwitchB-bgp] peer 200.1.1.2 as-number 65008

    Configure the iBGP connection:

    [SwitchB-bgp] peer 9.1.1.2 as-number 65009

    Inject networks 200.1.1.0/24 and 9.1.1.0/24 to the BGP routing table:

    [SwitchB-bgp] network 200.1.1.0 24
    [SwitchB-bgp] network 9.1.1.0 24

    Enable GR capability for BGP:

    [SwitchB-bgp] graceful-restart

  3. Configure Switch C.

    Configure IP addresses for interfaces (omitted).

    Configure the iBGP connection:

    <SwitchC> system-view
    [SwitchC] bgp 65009
    [SwitchC-bgp] router-id 3.3.3.3
    [SwitchC-bgp] peer 9.1.1.1 as-number 65009

    Enable GR capability for BGP:

    [SwitchC-bgp] graceful-restart

  4. Verify the configuration:

    Ping Switch C on Switch A. Meanwhile, perform a Master/Subordinate switchover on Switch B. The ping operation is successful during the whole switchover process.

top

Configuring BFD for BGP

Network requirements:

As shown in Figure 9:

  • Configure OSPF as the IGP in AS 200.

  • Establish two iBGP connections between Switch A and Switch C. When both links are working, Switch C adopts the link Switch A<->Switch B<->Switch C to exchange packets with network 1.1.1.0/24. Configure BFD over the link. Then if the link fails, BFD can quickly detect the failure and notify it to BGP. Then the link Switch A<->Switch D<->Switch C takes effect immediately.

Figure 9: Network diagram for BFD for BGP configuration

Procedure:

  1. Configure IP addresses for interfaces (omitted).

  2. Configure OSPF (omitted) to ensure that Switch A and Switch C are reachable to each other.

  3. Configure BGP on Switch A.

    Establish two iBGP connections between Switch A and Switch C:

    <SwitchA> system-view
    [SwitchA] bgp 100
    [SwitchA-bgp] peer 3.0.2.2 as-number 200
    [SwitchA-bgp] peer 2.0.2.2 as-number 200
    [SwitchA-bgp] quit

    When the two links between Switch A and Switch C are both up, Switch C adopts the link Switch A<->Switch B<->Switch C to exchange packets with network 1.1.1.0/24. (Set a higher MED value for route 1.1.1.0/24 sent to peer 2.0.2.2 on Switch A.)

    • Create ACL 2000 to permit 1.1.1.0/24 to pass:

      [SwitchA] acl number 2000
      [SwitchA-acl-basic-2000] rule permit source 1.1.1.0 24
      [SwitchA-acl-basic-2000] quit

    • Create two route policies, apply_med_50 and apply_med_100. Policy apply_med_50 sets the MED for route 1.1.1.0/24 to 50. Policy apply_med_100 sets that to 100:

      [SwitchA] route-policy apply_med_50 permit node 10
      [SwitchA-route-policy] if-match acl 2000
      [SwitchA-route-policy] apply cost 50
      [SwitchA-route-policy] quit
      [SwitchA] route-policy apply_med_100 permit node 10
      [SwitchA-route-policy] if-match acl 2000
      [SwitchA-route-policy] apply cost 100
      [SwitchA-route-policy] quit

    • Apply routing policy apply_med_50 to routes outgoing to peer 3.0.2.2, and apply routing policy apply_med_100 to routes outgoing to peer 2.0.2.2:

      [SwitchA] bgp 100
      [SwitchA-bgp] peer 3.0.2.2 route-policy apply_med_50 export
      [SwitchA-bgp] peer 2.0.2.2 route-policy apply_med_100 export

      Configure BFD over the link to peer 3.0.2.2 so that when the link Switch A<->Switch B<->Switch C fails, BFD can quickly detect the failure and notify it to BGP, and then the link Switch A<->Switch D<->Switch C takes effect immediately:

      [SwitchA-bgp] peer 3.0.2.2 bfd
      [SwitchA-bgp] quit

  4. Configure BGP on Switch C:

    <SwitchC> system-vie
    [SwitchC] bgp 100
    [SwitchC-bgp] peer 3
    [SwitchC-bgp] peer 3
    [SwitchC-bgp] peer 2
    [SwitchC-bgp] quit

  5. Configure BFD parameters (the user can use default BFD parameters instead).

    Configure Switch A:

    [SwitchA] bfd session init-mode active
    [SwitchA] interface vlan-interface 100

    • Configure the minimum interval for transmitting BFD control packets as 500 milliseconds:

      [SwitchA-Vlan-interface100] bfd min-transmit-interval 500

    • Configure the minimum interval for receiving BFD control packets as 500 milliseconds:

      [SwitchA-Vlan-interface100] bfd min-receive-interval 500

    • Configure the detect multiplier as 7:

      [SwitchA-Vlan-interface100] bfd detect-multiplier 7

    • Configure the BFD authentication mode as plain-text authentication, and set the authentication key to ibgpbfd:

      [SwitchA-Vlan-interface100] bfd authentication-mode simple 1 ibgpbfd
      [SwitchA-Vlan-interface100] quit

    Configure Switch C:

    [SwitchC] bfd session init-mode active
    [SwitchC] interface vlan-interface 101
    [SwitchC-Vlan-interface101] bfd min-transmit-interval 500
    [SwitchC-Vlan-interface101] bfd min-receive-interval 500
    [SwitchC-Vlan-interface101] bfd detect-multiplier 7
    [SwitchC-Vlan-interface101] bfd authentication-mode simple 1 ibgpbfd
    [SwitchC-Vlan-interface101] return

  6. Verify the configuration.

    The following operations are made on Switch C. Operations on Switch A are similar and are omitted.

    Display detailed BFD session information:

    <SwitchC> display bfd session verbose

    Total Session Num: 1 Init Mode: Active

    IP Session Working Under Ctrl Mode:

    Local Discr: 17 Remote Discr: 13
    Source IP: 3.0.2.2 Destination IP: 3.0.1.1
    Session State: Up Interface: Vlan-interface101
    Min Trans Inter: 500ms Act Trans Inter: 500ms
    Min Recv Inter: 500ms Act Detect Inter: 3000ms
    Recv Pkt Num: 57 Send Pkt Num: 53
    Hold Time: 2200ms Connect Type: Indirect
    Running Up for: 00:00:06 Auth mode: Simple
    Protocol: BGP6
    Diag Info: No Diagnostic

    The output shows that a BFD session is established between Switch A VLAN-interface 100 and Switch C VLAN-interface 101 and that BFD runs properly.

    Display BGP peer information on Switch C, and the user can see that Switch C has established two BGP neighborships with Switch A:

    <SwitchC> display bgp peer

    BGP local router ID : 1.1.1.1
    Local AS number : 200
    Total number of peers : 2 Peers in established state : 2

    Peer AS MsgRcvd MsgSent OutQ PrefRcv Up/Down State

    2.0.1.1 200 7 10 0 0 00:01:05 Established
    3.0.1.1 200 7 10 0 0 00:01:34 Established

    Display route 1.1.1.0/24 on Switch C, and the user can see that Switch A and Switch C communicate through Switch B:

    <SwitchC> display ip routing-table 1.1.1.0 24 verbose
    Routing Table : Public
    Summary Count : 2

    Destination: 1.1.1.0/24
    Protocol: BGP Process ID: 0
    Preference: 0 Cost: 50
    NextHop: 3.0.1.1 Interface: Vlan-interface101
    BkNextHop: 0.0.0.0 BkInterface:
    RelyNextHop: 3.0.2.1 Neighbor : 3.0.1.1
    Tunnel ID: 0x0 Label: NULL
    State: Active Adv Age: 00h08m54s
    Tag: 0

    Destination: 1.1.1.0/24
    Protocol: BGP Process ID: 0
    Preference: 0 Cost: 100
    NextHop: 2.0.1.1 Interface: Vlan-interface201
    BkNextHop: 0.0.0.0 BkInterface:
    RelyNextHop: 2.0.2.1 Neighbor : 2.0.1.1
    Tunnel ID: 0x0 Label: NULL
    State: Invalid Adv Age: 00h08m54s
    Tag: 0

    The output shows that Switch C has two routes to reach network 1.1.1.0/24: Switch C<—>Switch B<—>Switch A, which is the active route; Switch C<—>Switch D<—>Switch A, which is the backup route.

    Enable BFD debugging on Switch C:

    <SwitchC> debugging bfd scm
    <SwitchC> debugging bfd event
    <SwitchC> debugging bgp bfd
    <SwitchC> terminal monitor
    <SwitchC> terminal debugging

    The following debugging information shows that: when the link between Switch A and Switch B fails, Switch C can quickly detect the link failure:

    %Nov 5 11:42:24:172 2009 SwitchC BFD/5/BFD_CHANGE_FSM: Sess[3.0.2.2/3.0.1 .1,
    13/17,VLAN101,Ctrl], Sta: UP->DOWN, Diag: 1
    %Nov 5 11:42:24:172 2009 SwitchC BGP/5/BGP_STATE_CHANGED: 3.0.1.1 state is changed from
    ESTABLISHED to IDLE.
    *Nov 5 11:42:24:187 2009 SwitchC RM/6/RMDEBUG: BGP_BFD: Recv BFD DOWN msg, Src IP
    3.0.2.2, Dst IP 3.0.1.1, Instance ID 0.
    *Nov 5 11:42:24:187 2009 SwitchC RM/6/RMDEBUG: BGP_BFD: Reset BGP session 3.0.1.1 for
    BFD session down.
    *Nov 5 11:42:24:187 2009 SwitchC RM/6/RMDEBUG: BGP_BFD: Send DELETE msg to BFD,
    Connection type DIRECT, Src IP 3.0.2.2, Dst IP 3.0.1.1, Instance ID 0.

    Display route 1.1.1.0/24 on Switch C, and the user can see that Switch A and Switch C communicate through Switch D:

    <SwitchC> display ip routing-table 1.1.1.0 24 verbose
    Routing Table : Public
    Summary Count : 1

    Destination: 1.1.1.0/24
    Protocol: BGP Process ID: 0
    Preference: 0 Cost: 100
    NextHop: 2.0.1.1 Interface: Vlan-interface201
    BkNextHop: 0.0.0.0 BkInterface:
    RelyNextHop: 2.0.2.1 Neighbor : 2.0.1.1
    Tunnel ID: 0x0 Label: NULL
    State: Active Adv Age: 00h09m54s
    Tag: 0

    The output shows that Switch C has one route to reach network 1.1.1.0/24 (Switch C<->Switch D<->Switch A).

top

Provide feedback

Please rate the information on this page to help us improve our content. Thank you!